Не запускалась игра STAR WARS Knights of the Old Republic II

Иногда поигрываю на Linux'e в игры купленные в Steam, и вдруг после небольшого обновления дров и библиотек перестала запускаться игра STAR WARS Knights of the Old Republic II — The Sith Lords, битый час я гуглил проблему, но ничего из предложенного не помогло, на одном из форумов натолкнулся на ответ, что типа вся фигня из за дров nvidia, а именно версии nvidia-361.18 в лог сыпалось следующее:
ERROR: ld.so: object '/home/user/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/user/.steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored

И игра крашилась…
Попытался откатить на предыдущую версию дров(358), но не тут то было, они начали требовать ядро версии меньше 4.4… В общем ничего не осталось кроме как ждать(ставить из «нерепозитория», не было желания), и сегодня 10.02.2016 nvidia выпустила новые драйвера 361.28 [ https://www.linux.org.ru/ ], незамедлительно я обновился, перезапустил Xorg и игра запустилась.



Да прибудет с вами сила.

Русификатор, если вдруг кому нужен, держите: swkotor2sithlords_1_11.exe

Комментарии ()

    Есть вопрос или предложение пиши в Telegram @cloudsv

    Прямой эфир

    cloudsv 24 октября 2018, 00:27
    О жизни Обновление Scala Rider G4 0
    cloudsv 21 октября 2018, 23:16
    Arch Linux Памятка по основным утилитам Linux 0
    cloudsv 01 июня 2018, 01:39
    Telegram Настройка прокси mtproto для Telegram 28
    cloudsv 22 января 2018, 21:59
    Web Локальное зеркало обновлений Dr.web 0
    cloudsv 03 октября 2017, 10:55
    Web Пароль от резервной копии Bitrix 1
    cloudsv 09 июля 2017, 23:02
    Arch Linux Let's Encrypt это легко и просто 0